Page 2 of 3

Re: Oil issues

Posted: 16 Apr 2019, 15:40
by Vitus
I think I found the problem. Or better: I found a problem with the lubrication system.

The fix will be in 0.90 and hopefully resolve some related overheating issues of the engine as well. More testing is needed though.

Re: Oil issues

Posted: 16 Apr 2019, 17:36
by timmee62
Great! Hope getting the feedback from us helped..

Re: Oil issues

Posted: 16 Apr 2019, 18:26
by mthrift
Not to "pile on", but just to give a sense of how prevalent this might be, I also have the same issue with oil pressure.

Hasn't stopped me flying, though! :D


Michael

Re: Oil issues

Posted: 16 Apr 2019, 18:40
by Vitus
Guys, I couldn't do any of this without your help! Please keep reporting anything you see not working, even if I don't respond for some days I make notes of everything you post!

If you're interested:
the issue seems to be that when any line of the lubrication system runs dry, the mass of the oil is "0". And zeros screw up formulas :lol:
That's part of the reason why I am calculating absolute pressures rather than relative pressures - I try to prevent zeros from happening.

Re: Oil issues

Posted: 18 Apr 2019, 22:16
by timmee62
That makes sense now! I just watched Peter Matthess YouTube live stream of the Vega 5 and noticed he had the same oil issue during that flight, namely warning light on and pressure gauge very high. If I notice any other indicators during flights, I will post here.

Re: Oil issues

Posted: 19 Apr 2019, 16:52
by Vitus
...Thinking about this, maybe a solution lies in switching to Kelvin rather than Celsius to perform all those temperature calculations, thus avoiding the "0" altogether....

Re: Oil issues

Posted: 20 Apr 2019, 18:13
by timmee62
I guess it's always better to have a consistent form of measurement... Today I've been doing some circuits around LKHV where it's a warm day (18 deg c) and before the flight I refilled with SAE30 instead of just any oil (as I had done before reading properly which to use). No oil issues at all. Could using the wrong oil for the temp conditions outside be a factor?

Re: Oil issues

Posted: 21 Apr 2019, 13:25
by ricfishner
Hi timmee62,
how did you switch / refill with a new oil grade. It seems I did the same, initially filling it up with just some oil without proper reading which one to use (apperently I have a winter oil now). As I'm currently flying in warmer conditions, I do think the SAE30 would be a far better match. But can't find an option to drain the oil, nor can I just refill with a new one, since my oil tank is still full. Do I need to delete the data.dat file?

Re: Oil issues

Posted: 21 Apr 2019, 17:12
by timmee62
When I started my flight, I selected the Cold and Dark option from the sidebar menu. This seemed to empty the oil as it had been full on the previous flight and this had been a short flight. Not sure if it's meant to do this or not...

Re: Oil issues

Posted: 21 Apr 2019, 19:25
by ricfishner
Hi timmee62,

thanks, I'll try that. As I always left the Vega all nice and tidy, with all systems shut down and asked Heinrich to install wheel chocks and ropes, I didn't use the Cold&Dark option recently.